A weekly comic about programming, browsers and geek stuff.

Baby

We'd like to name him Peter. That names is already taken! Try Peter375 or Peter2099.
https://comic.browserling.com/57
Cartoon tags:
username, taken, baby, doctor, forum, message board, handle, internet handle, nickname, name, peter, peter375, peter2099, nick, login
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING57 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.