A weekly comic about programming, browsers and geek stuff.

Browser Wars 2018

The epic fight between browsers still goes on in 2018.
https://comic.browserling.com/98
Cartoon tags:
brower wars, ie, internet explorer, edge, brave browser, yandex browser, vivaldi browser, beaker browser, firefox, chrome, safari, opera, brave, yandex, vivaldi, beaker, war, wars, iexplore, iexplorer, explorer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING98 to get a discount on developer and team plans!
(c) 2018 Browserling Inc. All rights reserved.