A weekly comic about programming, browsers and geek stuff.

Browser Wars

Only the strong survive.
https://comic.browserling.com/65
Cartoon tags:
chrome, firefox, safari, opera, ie, internet explorer, iexplorer, iexplore, edge, browser, browsers, war, browser wars, alien, aliens, ufo, abduction, flying saucer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING65 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.