Weekly comic about computers, programmers, web developers and browsers.

List of all comics

Restaurant
Comic Sans
Grandma
Bar
Hotel
Where do you want to go today?
Graveyard
Cookie Monster
Browser History
Bathroom
SEO Expert
Home
Winamp
Shopping
Full Stack
Spaghetti
Test Engineer
Glasses
Table Layout
VIM
Dates
Floating
Tables
Homev6
Java
Hobbit
Sleep
Keyboard
1023MB
Twins
Sweet Home
Dinosaurs
Halloween
The Terminator
Coldness
Chips
Home Sweet Home
Titanic
Binary
Refreshments
Coffee
Tower of Pisa
Europe
Home Sweet Home
Ninja
Internet Explorer
Ship
Big Bang
Punch Cards
3AM
Ghost
Tux Party
Threads
Mendeleev
Opera
Lego
Baby
Bytes
Hammer
Self Portrait
DOM and jQuery
ASCII/ANSI
Love Story
Jon 'maddog' Hall
Browser Wars
Hide and Seek
Merry Christmas
After New Year's Party
Titanic and Iceberg
Viking
Eight Bytes
Programmer (noun)
Turing
Winners
Grace Hopper
Chrome
Internet Explorer
Debugging
Psychopath
John McCarthy
Internet Exploder
Building Material
Modern Web Development
Browser War
Room 404
Expectation vs Reality
Needle Stack
Archimedes
Great Hackers
Linux Party
Ada Lovelace
Computers
Astronomy
Daemon
Larry Wall
Happy Holidays
Epic Computer Science Battles
Browser Wars
Anchors
Coders
Fear
Candy
Math Cows
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING to get a discount on developer and team plans!
(c) 2018 Browserling Inc. All rights reserved.


Restaurant

A web developer left a restaurant before ordering because he hated the menus. They were fold-outs and he prefers drop-downs.
<< < > >>
https://comic.browserling.com/1
Cartoon tags:
restaurant, menu, menus, dropdown, foldout, drop-down, fold-out, dropdowns, drop-downs, fold-outs, foldouts, waiter
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING1 to get a discount on developer and team plans!


Comic Sans

What did Times New Roman say to Comic Sans? - I hate your type!
<< < > >>
https://comic.browserling.com/2
Cartoon tags:
font, type, fonts, types, comic sans, sans, times new roman, new roman, roman, typography
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING2 to get a discount on developer and team plans!


Grandma

My grandma never got to experience the Internet. Not because she was too old, but because she used Internet Explorer.
<< < > >>
https://comic.browserling.com/3
Cartoon tags:
grandma, internet explorer, ie, internet, web, grand mom, grandmom, grand mother, grandmother, explorer, iexplorer, computer, iexplore.exe
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING3 to get a discount on developer and team plans!


Bar

While humans have to pay for each drink at the bar, a web browser can just open a tab.
<< < > >>
https://comic.browserling.com/4
Cartoon tags:
bar, human, humans, drink, drinks, browser, tab, browsers, tabs, bars, new tab, new tabs, cash, beer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING4 to get a discount on developer and team plans!


Hotel

A web page checked into a hotel. It was given room 404 and was never found since.
<< < > >>
https://comic.browserling.com/5
Cartoon tags:
hotel, 404, room, rooms, hotels, found, not found, missing, 404 not found, http, html, web page, webpage, web site, website
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING5 to get a discount on developer and team plans!


Where do you want to go today?

Internet Explorer does a great job of downloading Chrome.
<< < > >>
https://comic.browserling.com/6
Cartoon tags:
wdywtgt, ie, internet explorer, iexplore, explorer, iexplore.exe, chrome, google chrome, google, microsoft, where do you want to go today, download, install
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING6 to get a discount on developer and team plans!


Graveyard

.rip { bottom: -6ft; }
<< < > >>
https://comic.browserling.com/7
Cartoon tags:
rip, ie, css, internet explorer, graveyard, browser, bottom, grave, gravestone, cemetery, headstone, tombstone, iexplore, iexplorer, css joke, css pun
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING7 to get a discount on developer and team plans!


Cookie Monster

Cookie Monster discovers the Cookie Clicker game.
<< < > >>
https://comic.browserling.com/8
Cartoon tags:
cookie monster, cookie clicker, game, cookies, cookie, browser, browser cookies, chocolate chip cookies
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING8 to get a discount on developer and team plans!


Browser History

An empty Internet browser's history is an automatic admission of guilt.
<< < > >>
https://comic.browserling.com/9
Cartoon tags:
browser, history, guilty, guilt, internet browser, internet history, browser history, incognito, police, police man, web browser, browsers, innocent, not guilty, private browsing
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING9 to get a discount on developer and team plans!


Bathroom

What was the web developer doing in the bathroom? ... Taking a crop.
<< < > >>
https://comic.browserling.com/10
Cartoon tags:
crop, photoshop, bathroom, tool, crap, c, toilet, water, mirror, faucet, tools, photo shop, gimp, mspaint, paint, cropping
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING10 to get a discount on developer and team plans!


SEO Expert

An SEO expert walks into a bar, bars, pub, inn, tavern, public house, Irish pub, drink, drinks, beer, alcohol...
<< < > >>
https://comic.browserling.com/11
Cartoon tags:
seo, search engine optimization, bar, bars, pub, inn, tavern, public house, irish pub, drink, drinks, beer, alcohol, seo expert, expert, drunk
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING11 to get a discount on developer and team plans!


Home

There's no place like 127.0.0.1.
<< < > >>
https://comic.browserling.com/12
Cartoon tags:
127.0.0.1, home, lo, loopback, ip, ip address, loop back, dog, house, localhost, local host, dog, house, grass, door
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING12 to get a discount on developer and team plans!


Winamp

It really whips the llama's ass!
<< < > >>
https://comic.browserling.com/13
Cartoon tags:
winamp, llama, whip, mp3, music player, software
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING13 to get a discount on developer and team plans!


Shopping

Internet Explorer goes shopping. Employee asks, "Do you need help?" Internet Explorer responds, "No, just browsing."
<< < > >>
https://comic.browserling.com/14
Cartoon tags:
internet explorer, ie, shopping, shop, employee, browse, browsing, iexplore, explorer, iexplorer, iexplorer.exe, store
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING14 to get a discount on developer and team plans!


Full Stack

Front end vs Back end.
<< < > >>
https://comic.browserling.com/15
Cartoon tags:
front end, back end, frontend, backend, user, beauty, servers, server, interface, devops, dev ops, beast, front-end, back-end, api, sysadmin, sys admin, user, users
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING15 to get a discount on developer and team plans!


Spaghetti

Why did the Italian chef fail his web coding class? ... He wrote spaghetti from scratch.
<< < > >>
https://comic.browserling.com/16
Cartoon tags:
italian, italy, chef, coding, spaghetti, web coding, coding class, web coding, web coding class, class, fail, failed, failure, tomatoes, sphagetti, spagetti
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING16 to get a discount on developer and team plans!


Test Engineer

A test engineer walks into a bar and orders... test1 beertest testtesttest 111111 (*#% beer 484.
<< < > >>
https://comic.browserling.com/17
Cartoon tags:
test, testing, bar, beer, software testing, test engineer, barman, drink, drinks, alcohol, programming
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING17 to get a discount on developer and team plans!


Glasses

Why do Java developers wear glasses? ... Because they don't C#.
<< < > >>
https://comic.browserling.com/18
Cartoon tags:
java, developer, glasses, c#, c sharp, developers, computer, books, desk, computer, coffee, bookshelf
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING18 to get a discount on developer and team plans!


Table Layout

Why did the web developer leave the restaurant? ... Because of the table layout.
<< < > >>
https://comic.browserling.com/19
Cartoon tags:
restaurant, table, tables, table layout, layout, leave, html, html table, html tables
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING19 to get a discount on developer and team plans!


VIM

How do you generate a random string? ... Put a web designer in front of VIM and tell him to save and exit.
<< < > >>
https://comic.browserling.com/20
Cartoon tags:
vi, vim, string, random, save, exit, text editor, w, wq, ZZ, :w, ed, ctrl-c, ctrlc, random string, strings, clock, color palette, colors, palette, design, computer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING20 to get a discount on developer and team plans!


Dates

Why do programmers always mix up Halloween and Christmas? ... Because Oct 31 == Dec 25!
<< < > >>
https://comic.browserling.com/21
Cartoon tags:
halloween, christmas, oct, dec, 31, 25, octal, decimal, oct31, dec25, number system, number systems, base, bases, base conversion, numeral system, date, dates, christmas tree, vampire, radix, october, december
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING21 to get a discount on developer and team plans!


Floating

Why did the web designer drown?... She didn't know if she should float left or float right.",
<< < > >>
https://comic.browserling.com/22
Cartoon tags:
float, floating, web development, web, drown, left, right, float left, float right
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING22 to get a discount on developer and team plans!


Tables

An SQL query walks into a bar and sees two tables. He walks up to them and says "Can I join you?"
<< < > >>
https://comic.browserling.com/23
Cartoon tags:
sql, query, database, table, tables, databases, join, joins, sql queries, structured query language, mysql, postgresql, mariadb, redis, nosql, mongodb, bar, beer, drink, bartender, barman
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING23 to get a discount on developer and team plans!


Homev6

There's no place like ::1.
<< < > >>
https://comic.browserling.com/24
Cartoon tags:
ip, ipv6, loopback, loop back, home, lo, loopback street, localhost, local host, 1, house, wife, internet protocol, house, wife, cookies, grass
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING24 to get a discount on developer and team plans!


Java

Knock knock... Who's there?... ... very long pause ... Java!
<< < > >>
https://comic.browserling.com/25
Cartoon tags:
java, knock knock, who's there, long pause, slow, morning, night, house, door, knock knock joke, evening, light, moon
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING25 to get a discount on developer and team plans!


Hobbit

What do you call 8 hobbits?... A hobbyte.
<< < > >>
https://comic.browserling.com/26
Cartoon tags:
hobbit, hobbyte, bilbo baggins, hobit, bit, hobyte, byte, 8 hobbits, 1 hobbyte, halfling, halflings, hobbitat, jrr tolkien, john ronald reuel tolkien, fantasy
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING26 to get a discount on developer and team plans!


Sleep

4:04 AM. Sleep not found.
<< < > >>
https://comic.browserling.com/27
Cartoon tags:
sleep, not found, 404, http, 404 not found, am, morning, 4:04am, 04:04am, night, no sleep, nosleep, bed, room, web server, web page, html, response code
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING27 to get a discount on developer and team plans!


Keyboard

Keyboard not found... Press F1 to continue.
<< < > >>
https://comic.browserling.com/28
Cartoon tags:
keyboard, f1, bios, not found, continue, devops, sysadmin, system administrator, desk, x+y, pen, notepad, notes, computer, server, phone, window, wall
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING28 to get a discount on developer and team plans!


1023MB

There's a band called 1023MB. They haven't had a gig yet.
<< < > >>
https://comic.browserling.com/29
Cartoon tags:
1023MB, megabyte, 1GB, gigabyte, gig, band, music, 1023 MB, 1023 megabytes, 1 GB, 1 gigabyte, computer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING29 to get a discount on developer and team plans!


Twins

An SEO couple had twins. For the first time they were happy with duplicate content.
<< < > >>
https://comic.browserling.com/30
Cartoon tags:
seo, duplicate content, twins, couple, hospital, birth, labor, childbirth, phone, matt cutts
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING30 to get a discount on developer and team plans!


Sweet Home

127.0.0.1 sweet 127.0.0.1.
<< < > >>
https://comic.browserling.com/31
Cartoon tags:
home, localhost, 127.0.0.1, ipv4, ip, ip address, address, home sweet home, fireplace, laptop, lo, loopback, table, poster, hilbert curve, penrose tiling, toys, pokemon, pac-man, dog, super mario, yoshi, pokemon, pikachu, pokeball, goomba, books, cactus, super star
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING31 to get a discount on developer and team plans!


Dinosaurs

COBOL programming class.
<< < > >>
https://comic.browserling.com/32
Cartoon tags:
cobol, dinosaur, dinosaurs, lecture, programming, computers, common business-oriented language
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING32 to get a discount on developer and team plans!


Halloween

What does a computer scientist wear on Halloween?... A bit mask.
<< < > >>
https://comic.browserling.com/33
Cartoon tags:
computer scientist, compsci, bit mask, bitmask, mask, comp.sci, cs, computer science, bits, bit, halloween, vampire
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING33 to get a discount on developer and team plans!


The Terminator

Why didn't The Terminator upgrade to Windows 10?... Because he still loves Vista, baby!
<< < > >>
https://comic.browserling.com/34
Cartoon tags:
the terminator, windows, vista, windows 10, arnold schwarzenegger, arnie, t800, t-800, series 800 model 101, series 70, t850, windows vista, 10, winvista, win vista, win 10, win10, hasta la vista baby, machine gun, robots, windows installation dvd
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING34 to get a discount on developer and team plans!


Coldness

Why was the computer cold?... It left its Windows open!
<< < > >>
https://comic.browserling.com/35
Cartoon tags:
computer, cold, room, window, windows, microsoft windows, keyboard, microsoft natural keyboard, mouse, scarf, coldness, open
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING35 to get a discount on developer and team plans!


Chips

How do programmers like their burgers?... With chips.
<< < > >>
https://comic.browserling.com/36
Cartoon tags:
burgers, chips, burger, chip, table, fast food, comp chip burgers, computer chips, ram, cpu, ram chip, 8080, intel, amd
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING36 to get a discount on developer and team plans!


Home Sweet Home

::1 sweet ::1
<< < > >>
https://comic.browserling.com/37
Cartoon tags:
home, ipv6, localhost, sweet home, home sweet home, programmer, monitor, desk, coffee, dog, chair, laptop
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING37 to get a discount on developer and team plans!


Titanic

#titanic { float: none; }
<< < > >>
https://comic.browserling.com/38
Cartoon tags:
titanic, css, float, none, iceberg, water, selector, captain, lifebuoy, lifering, ship, floating, css selector, rms titanic, passenger liner
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING38 to get a discount on developer and team plans!


Binary

There are only 10 types of people in the world: Those who understand binary, and those who don't.
<< < > >>
https://comic.browserling.com/39
Cartoon tags:
binary, people, ten, two, bin, number system, 1, 0, one, zero, base, 1010, 00, 01, 10, 11, numeral system, dec, 2, radix
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING39 to get a discount on developer and team plans!


Refreshments

How do web developers order for refreshments?... They press F5!
<< < > >>
https://comic.browserling.com/40
Cartoon tags:
refresh, f5, refreshments, refreshment, restaurant, reload, web developers, snack, food, drink, cocktail, laptop, table, waiter, confusion
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING40 to get a discount on developer and team plans!


Coffee

Coffee in, code out.
<< < > >>
https://comic.browserling.com/41
Cartoon tags:
coffee, code, coffee in, code out, cico, coffee machine, programming
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING41 to get a discount on developer and team plans!


Tower of Pisa

#pisa-tower { font-style: italic; }
<< < > >>
https://comic.browserling.com/42
Cartoon tags:
pisa tower, css, font, italic, tower of pisa, font-style, cascading style sheet, laptop, tourists, tower, italy, leaning
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING42 to get a discount on developer and team plans!


Europe

#europe .country { border: none; }
<< < > >>
https://comic.browserling.com/43
Cartoon tags:
europe, eu, border, none, css, european union, earth, continent, borders, uk, brexit, england
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING43 to get a discount on developer and team plans!


Home Sweet Home

~ sweet ~
https://comic.browserling.com/44
Cartoon tags:
home, unix, linux, home directory, vi, vim, tilde, mug, coffee, text editor, home sweet home, sweet home, programmer, laptop, cat, dog, fireplace, lamp, picture, playstation, playstation 4, ps4, controllers, hexagon, transformers, godzilla, books, transformer, action figures, amazon alexa, newtons cradle, toys
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING44 to get a discount on developer and team plans!


Ninja

.ninja { visibility: hidden; color: black; }
<< < > >>
https://comic.browserling.com/45
Cartoon tags:
ninja, japan, css, html, visibility, hidden, color, black, sword, transparent, temple, shinobi
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING45 to get a discount on developer and team plans!


Internet Explorer

The only thing Internet Explorer is good for is downloading Firefox.
<< < > >>
https://comic.browserling.com/46
Cartoon tags:
ie, internet explorer, iexplore, explorer, microsoft, firefox, mozilla, mozilla firefox, download, install, wdywtgt, where do you want to go today, install firefox, download firefox, file, edit, view, favorites, tools, help, fox, earth
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING46 to get a discount on developer and team plans!


Ship

Front end vs Back end.
<< < > >>
https://comic.browserling.com/47
Cartoon tags:
ship, front end, back end, frontend, backend, user, servers, server, interface, devops, dev ops, beast, beasts, scary, front-end, back-end, api, sysadmin, sys admin, user, users, sea monster, monster, monsters, sea monsters, boat, ship, fish, clouds, calm, cruise
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING47 to get a discount on developer and team plans!


Big Bang

#big-bang::before { content: ""; }
<< < > >>
https://comic.browserling.com/48
Cartoon tags:
big bang, css, html, content, before, universe, inflation, cosmology, cosmic, selector, star, galaxy, hubble
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING48 to get a discount on developer and team plans!


Punch Cards

FORTRAN programming class.
<< < > >>
https://comic.browserling.com/49
Cartoon tags:
fortran, punch card, programming class, dinosaur, dinosaurs, punch cards, crt, class, fortran programming, formula translation, programming language, computers, programming, card
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING49 to get a discount on developer and team plans!


3AM

Programmers are the only people awake at 3am.
<< < > >>
https://comic.browserling.com/50
Cartoon tags:
programmer, 3am, night, moon, city, houses, light
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING50 to get a discount on developer and team plans!


Ghost

.ghost { color: white; opacity: 0.1; }
<< < > >>
https://comic.browserling.com/51
Cartoon tags:
ghost, css, scary, cascading style sheet, color, white, night, opacity, moon, dark, graveyard
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING51 to get a discount on developer and team plans!


Tux Party

Happy 25th Birthday, Linux!
<< < > >>
https://comic.browserling.com/52
Cartoon tags:
tux, linux, party, birthday, 25, birthday party, 25th birthday, ghost, bitmask, dinosaurs, java, internet explorer, wine, dog, balloons, punch cards
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING52 to get a discount on developer and team plans!


Threads

Knock knock! Race condition. Who's there?!
<< < > >>
https://comic.browserling.com/53
Cartoon tags:
threads, knock knock, whos there, race condition, thread, cpu, multithreading, synchronization, mutex, lock, critical section, semaphore
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING53 to get a discount on developer and team plans!


Mendeleev

.periodic { display: table; }
<< < > >>
https://comic.browserling.com/54
Cartoon tags:
periodic table, periodic, mendeleev, dmitry mendeleev, dmitri mendeleev, css, cascading style sheet, display, table, chemistry, chemist, chemical elements, elements, groups
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING54 to get a discount on developer and team plans!


Opera

Internet Explorer is one of the slowest tools for downloading Opera.
<< < > >>
https://comic.browserling.com/55
Cartoon tags:
opera, ie, internet explorer, download, install, iexplore, explorer, browser, browsers, o, download and install opera, download opera, install opera, wdywtgt, where do you want to go today, microsoft
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING55 to get a discount on developer and team plans!


Lego

.lego { display: block; }
<< < > >>
https://comic.browserling.com/56
Cartoon tags:
lego, css, block, blocks, laptop, lego block, toys
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING56 to get a discount on developer and team plans!


Baby

We'd like to name him Peter. That names is already taken! Try Peter375 or Peter2099.
<< < > >>
https://comic.browserling.com/57
Cartoon tags:
username, taken, baby, doctor, forum, message board, handle, internet handle, nickname, name, peter, peter375, peter2099, nick, login
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING57 to get a discount on developer and team plans!


Bytes

Two bytes meet. The first byte asks, "Are you ill?" The second byte replies, "No, just feeling a bit off."
<< < > >>
https://comic.browserling.com/58
Cartoon tags:
bytes, 11111111, 11111110, bits, bit, ill, sick, off, bar, drinks, byte, hardware
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING58 to get a discount on developer and team plans!


Hammer

When your hammer is C++, everything begins to look like a thumb.
<< < > >>
https://comic.browserling.com/59
Cartoon tags:
hammer, thumb, injury, programming, desk, computers, cpp, cpp language, c plus plus, programming language
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING59 to get a discount on developer and team plans!


Self Portrait

2.71828182845904523536028747135266249775724709369995...
https://comic.browserling.com/60
Cartoon tags:
self portrait, e, ie, internet explorer, iexplorer, explorer, e constant, constant, math, norman rockwell, mathematical constant, math constant, 2.7, 2.71, 2.718, 2.7182, 2.71828, sum, series, sinh, cosh, euler, art, paint, canvas, irrational, studio, portrait
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING60 to get a discount on developer and team plans!


DOM and jQuery

Tom and Jerry.
<< < > >>
https://comic.browserling.com/61
Cartoon tags:
tom, jerry, dom, jquery, tom and jerry, browser, browsers, mouse, cat, cartoon, document object model
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING61 to get a discount on developer and team plans!


ASCII/ANSI

ASCII a stupid question, get a stupid ANSI.
<< < > >>
https://comic.browserling.com/62
Cartoon tags:
ascii, ansi, question, answer, ask, stupid, ascii art, ansi art
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING62 to get a discount on developer and team plans!


Love Story

PS. I love you!
<< < > >>
https://comic.browserling.com/63
Cartoon tags:
love, story, adobe, ps, ai, photoshop, illustrator, adobe photoshop, adobe illustrator
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING63 to get a discount on developer and team plans!


Jon 'maddog' Hall

UNIX - LIVE FREE OR DIE
https://comic.browserling.com/64
Cartoon tags:
unix, maddog, live free or die, jon hall, jon maddog hall, license plate, california, bell labs, highway, jeep wrangler, 1989 jeep wrangler, new hampshire, car, linux, computer scientist
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING64 to get a discount on developer and team plans!


Browser Wars

Only the strong survive.
<< < > >>
https://comic.browserling.com/65
Cartoon tags:
chrome, firefox, safari, opera, ie, internet explorer, iexplorer, iexplore, edge, browser, browsers, war, browser wars, alien, aliens, ufo, abduction, flying saucer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING65 to get a discount on developer and team plans!


Hide and Seek

Programming hide and seek championship.
<< < > >>
https://comic.browserling.com/66
Cartoon tags:
hide and seek, championship, programming, winner, first place, second place, third place, semicolon, parenthesis, curly braces
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING66 to get a discount on developer and team plans!


Merry Christmas

Merry browsery Christmas and Happy browsery New Year 2017!
<< < > >>
https://comic.browserling.com/67
Cartoon tags:
christmas, new year, merry christmas, happy new year, happy holidays, browser, browsers, opera, safari, chrome, firefox, internet explorer, ie, ram, wine, edge, tux, christmas tree, confetti, 2016, 2017
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING67 to get a discount on developer and team plans!


After New Year's Party

Partying with browsers is a bad idea.
<< < > >>
https://comic.browserling.com/68
Cartoon tags:
christmas, new year, aftermath, holidays, browser, browsers, opera, safari, chrome, firefox, internet explorer, ie, edge, tux, christmas tree, ram, drunk, drinks, bad idea, passed out
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING68 to get a discount on developer and team plans!


Titanic and Iceberg

#titanic { position: absolute; bottom: 0; } .iceberg { display: block; }.
<< < > >>
https://comic.browserling.com/69
Cartoon tags:
titanic, iceberg, css, bottom, block, ship, css selector, captain, lifebuoy, lifering, rms titanic, passenger liner, water, ice, display, block
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING69 to get a discount on developer and team plans!


Viking

What do you call a programmer from Finland?... A Nerdic!
<< < > >>
https://comic.browserling.com/70
Cartoon tags:
viking, nerd, nordic, nerdic, finland, sword, axe, winter, mountains, snow, cold, laptop, programmer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING70 to get a discount on developer and team plans!


Eight Bytes

Eight bytes walk into a bar. The barman asks, \"Can I get you anything?\" The bytes reply, \"Yeah, make us a double!\"
<< < > >>
https://comic.browserling.com/71
Cartoon tags:
bytes, double, whiskey, bar, drink, drinks, byte, eight bytes, 8 bytes, double precision, long long, barman, bits, 64 bits, floating point, decimal64
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING71 to get a discount on developer and team plans!


Programmer (noun)

A machine that turns coffee into code.
<< < > >>
https://comic.browserling.com/72
Cartoon tags:
programmer, coffee, code, noun, programming, machine, coffee machine, night, moon, stars, books, coffee beans
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING72 to get a discount on developer and team plans!


Turing

Debugging programs on infinite tapes isn't easy.
<< < > >>
https://comic.browserling.com/73
Cartoon tags:
turing, alan turing, turing machine, computing, tape, infinite tape, 1, 0, bug, busy beaver, computer scientist
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING73 to get a discount on developer and team plans!


Winners

LISP programming hide and seek championship.
<< < > >>
https://comic.browserling.com/74
Cartoon tags:
grace hopper, light, c, nanosecond, ns, foot, ft, computer scientist, admiral, formulas, speed of light, math
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING74 to get a discount on developer and team plans!


Grace Hopper

Light travels 1 foot in 1 nanosecond.
<< < > >>
https://comic.browserling.com/75
Cartoon tags:
lisp, hide and seek, championship, programming, programming language, first place, parenthesis, winners
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING75 to get a discount on developer and team plans!


Chrome

The hungriest browser.
<< < > >>
https://comic.browserling.com/76
Cartoon tags:
chrome, browser, ram, memory, hungry, hunger, food, fat
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING76 to get a discount on developer and team plans!


Internet Explorer

#ie { break-inside: auto; }
<< < > >>
https://comic.browserling.com/77
Cartoon tags:
ie, internet explorer, css, browser, break inside, auto, css selector, explorer, iexplore, iexplorer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING77 to get a discount on developer and team plans!


Debugging

Removing the needles from the haystack.
<< < > >>
https://comic.browserling.com/78
Cartoon tags:
debug, debugging, needle, haystack, hay, programmer, programming, needles, computers
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING78 to get a discount on developer and team plans!


Psychopath

Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live.
<< < > >>
https://comic.browserling.com/79
Cartoon tags:
code, psychopath, night, programming, best coding practices, software development
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING79 to get a discount on developer and team plans!


John McCarthy

The creator.
<< < > >>
https://comic.browserling.com/80
Cartoon tags:
john mccarthy, lisp, robots, chess, pawn, knight, symbolics, ai, artificial intelligence
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING80 to get a discount on developer and team plans!


Internet Exploder

Everyone's preferred browser.
<< < > >>
https://comic.browserling.com/81
Cartoon tags:
ie, internet explorer, internet exploder, bomb, timer, explosion, iexplore, iexplorer, explorer, iexploder, exploder, iexplode, 1 second
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING81 to get a discount on developer and team plans!


Building Material

Lisp isn't a language, it's a building material.
<< < > >>
https://comic.browserling.com/82
Cartoon tags:
lisp, alan kay, programming language, parenthesis, parens, building
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING82 to get a discount on developer and team plans!


Modern Web Development

Front End vs Back End.
<< < > >>
https://comic.browserling.com/83
Cartoon tags:
front end, back end, full stack, ui, ux, user interface, user experience, web development, web, cooking, food, cake, happy, kitchen
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING83 to get a discount on developer and team plans!


Browser War

The never ending war.
<< < > >>
https://comic.browserling.com/84
Cartoon tags:
chrome, firefox, safari, opera, ie, internet explorer, iexplorer, iexplore, edge, browser, browsers, war, browser war, browser wars
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING84 to get a discount on developer and team plans!


Room 404

Web developers always have trouble finding room 404.
<< < > >>
https://comic.browserling.com/85
Cartoon tags:
hotel, room, http, not found, 404, 404 not found, web server, response code, key, booking, 403, 405, 406
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING85 to get a discount on developer and team plans!


Expectation vs Reality

It's always harder than you think.
<< < > >>
https://comic.browserling.com/86
Cartoon tags:
expectation, reality, startup, startups, new project, maze, labyrinth, success
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING86 to get a discount on developer and team plans!


Needle Stack

Software debugging is like finding the hay in the needle stack.
<< < > >>
https://comic.browserling.com/87
Cartoon tags:
debug, debugging, needle, needle stack, hay, programmer, programming, software, needles, computers
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING87 to get a discount on developer and team plans!


Archimedes

Give me the command line and I shall move the world.
<< < > >>
https://comic.browserling.com/88
Cartoon tags:
archimedes, planet, earth, world, command line, shell, archie, laptop, bash, planets, greece, philosophy, philosopher, quote
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING88 to get a discount on developer and team plans!


Great Hackers

What you thought great hackers look like vs. what they really are like.
<< < > >>
https://comic.browserling.com/89
Cartoon tags:
hacker, hackers, simplicity, award, trash, pc, computer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING89 to get a discount on developer and team plans!


Linux Party

Happy 26th birthday, Linux!
<< < > >>
https://comic.browserling.com/90
Cartoon tags:
tux, linux, birthday, wine, party, 26, birthday party, cat, cake, laptop, slackware, chrome, hobbit, dog, girl, jeff bezos, archimedes
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING90 to get a discount on developer and team plans!


Ada Lovelace

Happy Ada Lovelace day!
<< < > >>
https://comic.browserling.com/91
Cartoon tags:
ada lovelace, charles babbage, analytical engine, analytic engine, difference engine, gears, computer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING91 to get a discount on developer and team plans!


Computers

Computers are useless. They can only give you answers. - Pablo Picasso
<< < > >>
https://comic.browserling.com/92
Cartoon tags:
computer, computers, pablo picasso, answer, answers, useless, quote, debian, mouse, monitor, keyboard, pc, case
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING92 to get a discount on developer and team plans!


Astronomy

Computer science is no more about computers than astronomy is about telescopes.
<< < > >>
https://comic.browserling.com/93
Cartoon tags:
dijkstra, edsger dijkstra, computer science, astronomy, telescope, computer, telescopes, computers, quote, edsger dijkstra, sky, universe, cosmos, programming, cs, compsci
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING93 to get a discount on developer and team plans!


Daemon

There are two major products that came out of Berkeley: LSD and UNIX. We do not believe this to be a coincidence.
<< < > >>
https://comic.browserling.com/94
Cartoon tags:
berkeley, bsd, lsd, unix, daemon, beastie, demon, quote
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING94 to get a discount on developer and team plans!


Larry Wall

The three great virtues of a programmer are laziness, impatience, and hubris.
<< < > >>
https://comic.browserling.com/95
Cartoon tags:
larry wall, perl, camelia, camel, selfie, quote, laziness, impatience, hubris, perl 5, perl 6, desert, cs, hippy, programming language, programming, computer scientist
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING95 to get a discount on developer and team plans!


Happy Holidays

Browserful Christmas and Browserful New Year 2018!
<< < > >>
https://comic.browserling.com/96
Cartoon tags:
christmas, new year, hat, browserify, mage, browser, browsers, chrome, edge, firefox, opera, safari, snowman, holidays, merry christmas, happy new year, 2017, ufo
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING96 to get a discount on developer and team plans!


Epic Computer Science Battles

Donald Knuth and literate programming vs. Douglas McIlroy and UNIX one-liners.
<< < > >>
https://comic.browserling.com/97
Cartoon tags:
knuth, mcilroy, literate programming, one liners, unix, computer science, battle, donald knuth, douglas mcilroy, programming, terminal, shell
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING97 to get a discount on developer and team plans!


Browser Wars

The fight between browsers still goes on!
<< < > >>
https://comic.browserling.com/98
Cartoon tags:
brower wars, ie, internet explorer, edge, brave browser, yandex browser, vivaldi browser, beaker browser, firefox, chrome, safari, opera, brave, yandex, vivaldi, beaker, war, wars, iexplore, iexplorer, explorer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING98 to get a discount on developer and team plans!


Anchors

Why did the web developer drown?... He had too many anchors.
<< < > >>
https://comic.browserling.com/99
Cartoon tags:
anchor, anchors, a tag, html, html tags, web, drown, web developer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING99 to get a discount on developer and team plans!


Coders

Good coders code, great coders reuse.
<< < > >>
https://comic.browserling.com/100
Cartoon tags:
good coders, great coders, reuse, peter krumins, quote, code, coding, coders, programming, programmers, architect, building, construction, software reuse, crane, home
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING100 to get a discount on developer and team plans!


Fear

Fear - display none - CSS Pun
https://comic.browserling.com/101
Cartoon tags:
fear, horror, horror movie, css, css pun, samara, the ring, popcorn
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING101 to get a discount on developer and team plans!


Candy

Candy in, code out.
<< < > >>
https://comic.browserling.com/102
Cartoon tags:
candy, code, candy in, code out, cico, sweets, chocolate, lollipop, cookie, cake, chocolates, lollipops, cookies, cakes, candies, programming
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING102 to get a discount on developer and team plans!


Math Cows

Cows are good at cow-culus.
<< < > >>
https://comic.browserling.com/103
Cartoon tags:
math, cow, cows, functions, x, y
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING103 to get a discount on developer and team plans!


1. A web developer left a restaurant before ordering because he hated the menus. They were fold-outs and he prefers drop-downs.
2. What did Times New Roman say to Comic Sans? - I hate your type!
3. My grandma never got to experience the Internet. Not because she was too old, but because she used Internet Explorer.
4. While humans have to pay for each drink at the bar, a web browser can just open a tab.
5. A web page checked into a hotel. It was given room 404 and was never found since.
6. Internet Explorer does a great job of downloading Chrome.
7. .rip { bottom: -6ft; }
8. Cookie Monster discovers the Cookie Clicker game.
9. An empty Internet browser's history is an automatic admission of guilt.
10. What was the web developer doing in the bathroom? ... Taking a crop.
11. An SEO expert walks into a bar, bars, pub, inn, tavern, public house, Irish pub, drink, drinks, beer, alcohol...
12. There's no place like 127.0.0.1.
13. It really whips the llama's ass!
14. Internet Explorer goes shopping. Employee asks, "Do you need help?" Internet Explorer responds, "No, just browsing."
15. Front end vs Back end.
16. Why did the Italian chef fail his web coding class? ... He wrote spaghetti from scratch.
17. A test engineer walks into a bar and orders... test1 beertest testtesttest 111111 (*#% beer 484.
18. Why do Java developers wear glasses? ... Because they don't C#.
19. Why did the web developer leave the restaurant? ... Because of the table layout.
20. How do you generate a random string? ... Put a web designer in front of VIM and tell him to save and exit.
21. Why do programmers always mix up Halloween and Christmas? ... Because Oct 31 == Dec 25!
22. Why did the web designer drown?... She didn't know if she should float left or float right.",
23. An SQL query walks into a bar and sees two tables. He walks up to them and says "Can I join you?"
24. There's no place like ::1.
25. Knock knock... Who's there?... ... very long pause ... Java!
26. What do you call 8 hobbits?... A hobbyte.
27. 4:04 AM. Sleep not found.
28. Keyboard not found... Press F1 to continue.
29. There's a band called 1023MB. They haven't had a gig yet.
30. An SEO couple had twins. For the first time they were happy with duplicate content.
31. 127.0.0.1 sweet 127.0.0.1.
32. COBOL programming class.
33. What does a computer scientist wear on Halloween?... A bit mask.
34. Why didn't The Terminator upgrade to Windows 10?... Because he still loves Vista, baby!
35. Why was the computer cold?... It left its Windows open!
36. How do programmers like their burgers?... With chips.
37. ::1 sweet ::1
38. #titanic { float: none; }
39. There are only 10 types of people in the world: Those who understand binary, and those who don't.
40. How do web developers order for refreshments?... They press F5!
41. Coffee in, code out.
42. #pisa-tower { font-style: italic; }
43. #europe .country { border: none; }
44. ~ sweet ~
45. .ninja { visibility: hidden; color: black; }
46. The only thing Internet Explorer is good for is downloading Firefox.
47. Front end vs Back end.
48. #big-bang::before { content: ""; }
49. FORTRAN programming class.
50. Programmers are the only people awake at 3am.
51. .ghost { color: white; opacity: 0.1; }
52. Happy 25th Birthday, Linux!
53. Knock knock! Race condition. Who's there?!
54. .periodic { display: table; }
55. Internet Explorer is one of the slowest tools for downloading Opera.
56. .lego { display: block; }
57. We'd like to name him Peter. That names is already taken! Try Peter375 or Peter2099.
58. Two bytes meet. The first byte asks, "Are you ill?" The second byte replies, "No, just feeling a bit off."
59. When your hammer is C++, everything begins to look like a thumb.
60. 2.71828182845904523536028747135266249775724709369995...
61. Tom and Jerry.
62. ASCII a stupid question, get a stupid ANSI.
63. PS. I love you!
64. UNIX - LIVE FREE OR DIE
65. Only the strong survive.
66. Programming hide and seek championship.
67. Merry browsery Christmas and Happy browsery New Year 2017!
68. Partying with browsers is a bad idea.
69. #titanic { position: absolute; bottom: 0; } .iceberg { display: block; }.
70. What do you call a programmer from Finland?... A Nerdic!
71. Eight bytes walk into a bar. The barman asks, \"Can I get you anything?\" The bytes reply, \"Yeah, make us a double!\"
72. A machine that turns coffee into code.
73. Debugging programs on infinite tapes isn't easy.
74. LISP programming hide and seek championship.
75. Light travels 1 foot in 1 nanosecond.
76. The hungriest browser.
77. #ie { break-inside: auto; }
78. Removing the needles from the haystack.
79. Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live.
80. The creator.
81. Everyone's preferred browser.
82. Lisp isn't a language, it's a building material.
83. Front End vs Back End.
84. The never ending war.
85. Web developers always have trouble finding room 404.
86. It's always harder than you think.
87. Software debugging is like finding the hay in the needle stack.
88. Give me the command line and I shall move the world.
89. What you thought great hackers look like vs. what they really are like.
90. Happy 26th birthday, Linux!
91. Happy Ada Lovelace day!
92. Computers are useless. They can only give you answers. - Pablo Picasso
93. Computer science is no more about computers than astronomy is about telescopes.
94. There are two major products that came out of Berkeley: LSD and UNIX. We do not believe this to be a coincidence.
95. The three great virtues of a programmer are laziness, impatience, and hubris.
96. Browserful Christmas and Browserful New Year 2018!
97. Donald Knuth and literate programming vs. Douglas McIlroy and UNIX one-liners.
98. The fight between browsers still goes on!
99. Why did the web developer drown?... He had too many anchors.
100. Good coders code, great coders reuse.
101. Fear - display none - CSS Pun
102. Candy in, code out.
103. Cows are good at cow-culus.
Extra 1. Web design is a lot like Vegas. What happens below the fold stays below the fold.
Extra 2. How do coders like their burgers?... With chips!
Extra 3. How do programmers order for refreshments?... They press F5!
Extra 4. Two fonts meet in Rome. One asks, \"Are you a Roman, too?\" \"No,\" the other responds, \"but I'm an Italic!\"
Extra 5. #pisa-tower { font-style: italic; }
Extra 6. What did the typographer say to the printer who wouldn't stop talking?... Get to the point!
Extra 7. What did the devops guy say?... Let's run Docker in Vagrant on EC2. Fifteen minute deploys are OK!
Extra 8. How do programming champions start their programs?... int result[500000];";
Extra 9. The only person awake at 3am.
Extra 10. .periodic { display: table; }
Extra 11. EA Programming Team
Extra 12. We'd like to name him James. That names is already taken! Try James375 or James2099.
Extra 13. DOM and jQuery.
Extra 14. Two robots meet. The first robot asks, "Are you ill?" The second robot replies, "No, just feeling a bit off."
Extra 15. ASCII a silly question, get a silly ANSI.
Extra 16. 3.14159265358979323846264338327950288419716939937510...
Extra 17. ASCII a stupid question, get a stupid ANSI.
Extra 18. Merry browserful Christmas and Happy browserful New Year 2017!
Extra 19. Why is Peter Pan always flying? Because he Neverlands.
Extra 20. C++ hide and seek championship.
Extra 21. Greek cows say mu!
Extra 22. Debugging is like finding a needle in the haystack.
Extra 23. What do you call a programmer from Sweden?... A Nerdic!
Extra 24. My grandpa never got to experience the Internet. Not because he was too old, but because he used Internet Explorer.
Extra 25. Debugging is the art of extracting the needles from the haystack.
Extra 26. Modern Web Development.
Extra 27. 4:04 AM. Sleep not found.
Extra 28. There are eight hobbits in a hobbyte.
Extra 29. If you wish to make an apple pie from scratch, you must first invent the Universe.
Extra 30. Why do Java developers wear glasses? ... Because they don't C#.
Extra 31. An empty Internet browser is an automatic admission of guilt.
Extra 32. Scheme programming hide and seek championship.
Extra 33. Day vs night.
Extra 34. Jeff Bezos: \"Alexa, buy me berries from Whole Foods!\" Alexa: \"Ok, Jeff, I just bought Whole Foods.\"
Extra 35. Expectation vs reality: Creating successful products is super difficult.
Extra 36. How do you generate a random string? ... Put a web designer in front of VIM and tell him to save and exit.
Extra 37. Web developers keep confusing The Times newspaper with the Times New Roman font.
Extra 38. An SEO expert walks into a bar, bars, pub, inn, tavern, public house, Irish pub, drink, drinks, beer, alcohol...
Extra 39. Computers are like air conditioners. They work fine until you start opening windows.
Extra 40. Computers are useless. They can only give you answers. - Pablo Picasso
Extra 41. An SEO couple had twins. For the first time they were happy with duplicate content.
Extra 42. ~ sweet ~
Extra 43. I had a life once. Now I have a computer.
Extra 44. Front end vs back end.
Extra 45. 127.0.0.1 sweet 127.0.0.1.
Extra 46. Literate programming vs shell one-liners. Who will win?!
Extra 47. Cookie Monster loves browser cookies.
Extra 48. Why did the computer keep sneezing?... It had a virus!
Extra 49. We sent a web developer to the store to get The Times newspaper. He came back with The Times New Roman.
Extra 50. The programmer forgot to update Java, so he went to the coffee shop to get a fresh one.
Extra 51. How do you know when you're really in incognito mode? ... Your browser turns into a Word document.
Extra 52. Real hacker's attack vectors are normalized.
Extra 53. Why did the programmer drown?... Because he shouted "F1! F1!" and no one could understand him.
Extra 54. Winamp - it really whips the llama's ass!
Extra 55. Minecraft - display block - CSS Pun
Extra 56. Boom! Tetris for Jonas!
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING to get a discount on developer and team plans!


List of all comics

Vegas
Burgers
F5 Refresh
Rome
Pisa Tower
Printer
Devops Guy
International Olympiad in Informatics
CEO of Browserling
Chemistry
EA Games
Baby
Tom and Jerry
Robots
Question
Pi's Self Portrait
ASCII a Question
Happy Holidays
Peter Pan
Programming Championship
Cows
Needle in the Haystack
Nordic
Grandpa
Art of Debugging
Front End vs Back End
No Sleep
Hobbyte
Apple Pie
Bad Vision
Browsing History
Parenthesis
Front End vs Back End
How Jeff Bezos Bought Whole Foods
Starting a New Project
Designer and Text Editor
Times New Roman
SEO Expert
Air Conditioners
Pablo Picasso
SEO Couple
Home Sweet Home
Life
Full Stack Development
Sweet Home
Don Knuth vs Doug McIlroy
Cookie Monster
Virus
Newspaper
Java Cafe
Incognito
Attack Vectors
F1
Llama
Minecraft
Tetris
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING to get a discount on developer and team plans!


Vegas

Web design is a lot like Vegas. What happens below the fold stays below the fold.
<< < > >>
https://comic.browserling.com/extra/1
Cartoon tags:
vegas, las vegas, fold, below fold, browser, marketing, money, drink, drinks, drinking, champagne, rich, nevada
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING1 to get a discount on developer and team plans!


Burgers

How do coders like their burgers?... With chips!
<< < > >>
https://comic.browserling.com/extra/2
Cartoon tags:
burgers, chips, coders, coder, chip, fries, fast food, computer chips, ram, rom, cpu, intel, amd
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING2 to get a discount on developer and team plans!


F5 Refresh

How do programmers order for refreshments?... They press F5!
<< < > >>
https://comic.browserling.com/extra/3
Cartoon tags:
f5, refresh, cafe, browserling cafe, refreshments, confusion, confused, waiter, laptop, table, arrows, refreshment, food
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING3 to get a discount on developer and team plans!


Rome

Two fonts meet in Rome. One asks, \"Are you a Roman, too?\" \"No,\" the other responds, \"but I'm an Italic!\"
<< < > >>
https://comic.browserling.com/extra/4
Cartoon tags:
rome, roman, italy, italic, colosseum, font, fonts, typography, type
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING4 to get a discount on developer and team plans!


Pisa Tower

#pisa-tower { font-style: italic; }
<< < > >>
https://comic.browserling.com/extra/5
Cartoon tags:
tower of pisa, pisa tower, tourist, tourists, css, italic, font-style, cascading style sheet, camera, photo camera, tower, italy, tuscany
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING5 to get a discount on developer and team plans!


Printer

What did the typographer say to the printer who wouldn't stop talking?... Get to the point!
<< < > >>
https://comic.browserling.com/extra/6
Cartoon tags:
printer, printing, typography, typographer, talking, laptop, point
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING6 to get a discount on developer and team plans!


Devops Guy

What did the devops guy say?... Let's run Docker in Vagrant on EC2. Fifteen minute deploys are OK!
<< < > >>
https://comic.browserling.com/extra/7
Cartoon tags:
vagrant, docker, ec2, amazon ec2, cloud, server, servers, data center, devops, sysadmin, nic, amazon, deploy
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING7 to get a discount on developer and team plans!


International Olympiad in Informatics

How do programming champions start their programs?... int result[500000];";
<< < > >>
https://comic.browserling.com/extra/8
Cartoon tags:
ioi, programming competition, int, c, c language, international olympiad in informatics, programmers, programming champions, competition, competitive programming, olympiad
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING8 to get a discount on developer and team plans!


CEO of Browserling

The only person awake at 3am.
<< < > >>
https://comic.browserling.com/extra/9
Cartoon tags:
ceo, browserling, night, moon, 3am, city, houses, light
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING9 to get a discount on developer and team plans!


Chemistry

.periodic { display: table; }
<< < > >>
https://comic.browserling.com/extra/10
Cartoon tags:
periodic table, periodic, mendeleev, dmitry mendeleev, dmitri mendeleev, css, cascading style sheet, display, table, chemistry, chemist, chemical elements, elements, groups
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING10 to get a discount on developer and team plans!


EA Games

EA Programming Team
https://comic.browserling.com/extra/11
Cartoon tags:
ea, ea games, electronic arts, dinosaurs, programming, team, mass effect
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING11 to get a discount on developer and team plans!


Baby

We'd like to name him James. That names is already taken! Try James375 or James2099.
<< < > >>
https://comic.browserling.com/extra/12
Cartoon tags:
baby, robot, robots, factory forum, message board, handle, internet handle, nickname, name, james, james375, james2099
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING12 to get a discount on developer and team plans!


Tom and Jerry

DOM and jQuery.
<< < > >>
https://comic.browserling.com/extra/13
Cartoon tags:
tom, jerry, dom, jquery, tom and jerry, browser, browsers, mouse, cat, cartoon
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING13 to get a discount on developer and team plans!


Robots

Two robots meet. The first robot asks, "Are you ill?" The second robot replies, "No, just feeling a bit off."
<< < > >>
https://comic.browserling.com/extra/14
Cartoon tags:
robot, robots, bit, byte, bits, bytes, ill, sick, planet, moon, satellite, 11111111, 11111110, hardware, hills
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING14 to get a discount on developer and team plans!


Question

ASCII a silly question, get a silly ANSI.
<< < > >>
https://comic.browserling.com/extra/15
Cartoon tags:
ascii, ansi, ascii art, ansi art, question, answer, silly
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING15 to get a discount on developer and team plans!


Pi's Self Portrait

3.14159265358979323846264338327950288419716939937510...
https://comic.browserling.com/extra/16
Cartoon tags:
self portrait, portrait, pi, pi constant, constant, math, norman rockwell, mathematical constant, math constant, 3.14, 3.1415, sum, series, art, paint, canvas, irrational, studio
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING16 to get a discount on developer and team plans!


ASCII a Question

ASCII a stupid question, get a stupid ANSI.
<< < > >>
https://comic.browserling.com/extra/17
Cartoon tags:
ascii, ansi, ascii art, ansi art, question, answer, stupid
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING17 to get a discount on developer and team plans!


Happy Holidays

Merry browserful Christmas and Happy browserful New Year 2017!
<< < > >>
https://comic.browserling.com/extra/18
Cartoon tags:
christmas, new year, merry christmas, happy new year, happy holidays, browser, browsers, opera, safari, chrome, firefox, internet explorer, ie, christmas tree, browser tree, 2016, 2017, advisors, investors, panda, unicycle, google, snow
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING18 to get a discount on developer and team plans!


Peter Pan

Why is Peter Pan always flying? Because he Neverlands.
<< < > >>
https://comic.browserling.com/extra/19
Cartoon tags:
peter pan, neverland, fly, flying, ship, island, tink, tinker bell
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING19 to get a discount on developer and team plans!


Programming Championship

C++ hide and seek championship.
<< < > >>
https://comic.browserling.com/extra/20
Cartoon tags:
cpp, c plus plus, hide and seek, championship, programming, programming language, winner, first place, second place, third place, semicolon, parenthesis, curly braces, cpp language
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING20 to get a discount on developer and team plans!


Cows

Greek cows say mu!
<< < > >>
https://comic.browserling.com/extra/21
Cartoon tags:
cow, mu, greek, moo, letter, cows, alphabet, science
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING21 to get a discount on developer and team plans!


Needle in the Haystack

Debugging is like finding a needle in the haystack.
<< < > >>
https://comic.browserling.com/extra/22
Cartoon tags:
needle, haystack, debug, debugging, program, code, magnifying glass, hand lens, hay, programming
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING22 to get a discount on developer and team plans!


Nordic

What do you call a programmer from Sweden?... A Nerdic!
<< < > >>
https://comic.browserling.com/extra/23
Cartoon tags:
sweden, nerd, nordic, nerdic, viking, ship, laptop, programmer, mountains, water
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING23 to get a discount on developer and team plans!


Grandpa

My grandpa never got to experience the Internet. Not because he was too old, but because he used Internet Explorer.
<< < > >>
https://comic.browserling.com/extra/24
Cartoon tags:
grandpa, internet explorer, browser, ie, explorer, iexplore, iexplorer, grandpap, grandfather, computer, coffee, clock, grandpa joke
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING24 to get a discount on developer and team plans!


Art of Debugging

Debugging is the art of extracting the needles from the haystack.
<< < > >>
https://comic.browserling.com/extra/25
Cartoon tags:
magnet, debug, debugging, magnets, needle, needles, haystack, program, programs, programming, code, coding, hay
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING25 to get a discount on developer and team plans!


Front End vs Back End

Modern Web Development.
<< < > >>
https://comic.browserling.com/extra/26
Cartoon tags:
front end, back end, full stack, ui, ux, user interface, user experience, web development, web, island, rainbow, castle, birds, trees, water, monster, sea, sea monster, fish, octopus, shark, anglerfish
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING26 to get a discount on developer and team plans!


No Sleep

4:04 AM. Sleep not found.
<< < > >>
https://comic.browserling.com/extra/27
Cartoon tags:
sleep, not found, 404, http, 404 not found, am, morning, 4:04am, 04:04am, night, no sleep, nosleep, bed, room, lamp, girl, web server, web page, html, response code
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING27 to get a discount on developer and team plans!


Hobbyte

There are eight hobbits in a hobbyte.
<< < > >>
https://comic.browserling.com/extra/28
Cartoon tags:
hobbit, hobbyte, bilbo baggins, hobit, bit, hobyte, byte, 8 hobbits, 1 hobbyte, halfling, halflings, hobbitat, jrr tolkien, john ronald reuel tolkien, fantasy, shire, sword
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING28 to get a discount on developer and team plans!


Apple Pie

If you wish to make an apple pie from scratch, you must first invent the Universe.
<< < > >>
https://comic.browserling.com/extra/29
Cartoon tags:
carl sagan, apple pie, universe, cosmos, food, science, galaxy, galaxies, milky way
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING29 to get a discount on developer and team plans!


Bad Vision

Why do Java developers wear glasses? ... Because they don't C#.
<< < > >>
https://comic.browserling.com/extra/30
Cartoon tags:
java, developer, glasses, c#, c sharp, visual studio, glass, developers, vs, computer, jon skeet, skeet, c# in depth, c sharp in depth, book, desk
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING30 to get a discount on developer and team plans!


Browsing History

An empty Internet browser is an automatic admission of guilt.
<< < > >>
https://comic.browserling.com/extra/31
Cartoon tags:
browser, history, guilty, guilt, internet browser, internet history, browser history, incognito, police, police man, web browser, browsers, innocent, not guilty, private browsing
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING31 to get a discount on developer and team plans!


Parenthesis

Scheme programming hide and seek championship.
<< < > >>
https://comic.browserling.com/extra/32
Cartoon tags:
lisp, scheme, hide and seek, championship, programming language, programming, first place, second place, third place, parenthesis, parens, winners
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING32 to get a discount on developer and team plans!


Front End vs Back End

Day vs night.
<< < > >>
https://comic.browserling.com/extra/33
Cartoon tags:
front end, back end, full stack, ui, ux, user interface, user experience, elk, web, darkness, sun, water, birds, pasture, sky, day, night
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING33 to get a discount on developer and team plans!


How Jeff Bezos Bought Whole Foods

Jeff Bezos: \"Alexa, buy me berries from Whole Foods!\" Alexa: \"Ok, Jeff, I just bought Whole Foods.\"
<< < > >>
https://comic.browserling.com/extra/34
Cartoon tags:
amazon, jeff bezos, whole foods, alexa, amazon echo, echo, acquisition, business
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING34 to get a discount on developer and team plans!


Starting a New Project

Expectation vs reality: Creating successful products is super difficult.
<< < > >>
https://comic.browserling.com/extra/35
Cartoon tags:
expectation, reality, startup, startups, new project, success, hard, difficult, bike
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING35 to get a discount on developer and team plans!


Designer and Text Editor

How do you generate a random string? ... Put a web designer in front of VIM and tell him to save and exit.
<< < > >>
https://comic.browserling.com/extra/36
Cartoon tags:
vi, vim, string, random, save, exit, text editor, w, wq, ZZ, :w, ed, ctrl-c, ctrlc, random string, strings, clock, color palette, colors, palette, design, computer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING36 to get a discount on developer and team plans!


Times New Roman

Web developers keep confusing The Times newspaper with the Times New Roman font.
<< < > >>
https://comic.browserling.com/extra/37
Cartoon tags:
times new roman, the times, newspaper, dog, boss, web developer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING37 to get a discount on developer and team plans!


SEO Expert

An SEO expert walks into a bar, bars, pub, inn, tavern, public house, Irish pub, drink, drinks, beer, alcohol...
<< < > >>
https://comic.browserling.com/extra/38
Cartoon tags:
seo, search engine optimization, bar, bars, pub, inn, tavern, public house, irish pub, drink, drinks, beer, alcohol, seo expert, expert, drunk
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING38 to get a discount on developer and team plans!


Air Conditioners

Computers are like air conditioners. They work fine until you start opening windows.
<< < > >>
https://comic.browserling.com/extra/39
Cartoon tags:
air conditioner, windows, computer, user, fan, os, operating system, microsoft, microsoft windows
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING39 to get a discount on developer and team plans!


Pablo Picasso

Computers are useless. They can only give you answers. - Pablo Picasso
<< < > >>
https://comic.browserling.com/extra/40
Cartoon tags:
computer, computers, pablo picasso, answer, answers, useless, quote, debian, mouse, monitor, keyboard, pc, case
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING40 to get a discount on developer and team plans!


SEO Couple

An SEO couple had twins. For the first time they were happy with duplicate content.
<< < > >>
https://comic.browserling.com/extra/41
Cartoon tags:
seo, duplicate content, twins, couple, google, search engine, hospital, babies, matt cutts
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING41 to get a discount on developer and team plans!


Home Sweet Home

~ sweet ~
https://comic.browserling.com/extra/42
Cartoon tags:
home, unix, linux, home directory, vi, vim, tilde, text editor, home sweet home, sweet home, programmer, laptop, cat, dog, fireplace, lamp, flowers, window, picture, carpet
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING42 to get a discount on developer and team plans!


Life

I had a life once. Now I have a computer.
<< < > >>
https://comic.browserling.com/extra/43
Cartoon tags:
life, computer, fun, outside, inside, balloons, dog, cat, squirrel, rainbow, playground
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING43 to get a discount on developer and team plans!


Full Stack Development

Front end vs back end.
<< < > >>
https://comic.browserling.com/extra/44
Cartoon tags:
front end, back end, cat, meal, food, milk, shower, shampoo
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING44 to get a discount on developer and team plans!


Sweet Home

127.0.0.1 sweet 127.0.0.1.
<< < > >>
https://comic.browserling.com/extra/45
Cartoon tags:
home, localhost, sweet home, sweet localhost, lo, loopback, local host, 127.0.0.1, computer, fire, fireplace, fire place, ipv4, ip, ip address
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING45 to get a discount on developer and team plans!


Don Knuth vs Doug McIlroy

Literate programming vs shell one-liners. Who will win?!
<< < > >>
https://comic.browserling.com/extra/46
Cartoon tags:
knuth, mcilroy, literate programming, one liners, unix, computer science, battle, donald knuth, douglas mcilroy, programming, dragon curve, terminal, shell
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING46 to get a discount on developer and team plans!


Cookie Monster

Cookie Monster loves browser cookies.
<< < > >>
https://comic.browserling.com/extra/47
Cartoon tags:
cookie monster, monster, internet, web, cookie, cookies, web cookie, browser, browsers, browser cookie, browser cookies, c is for cookie
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING47 to get a discount on developer and team plans!


Virus

Why did the computer keep sneezing?... It had a virus!
<< < > >>
https://comic.browserling.com/extra/48
Cartoon tags:
virus, computer, sneeze, sneezing, computer virus, computer viruses, aaa choo, running nose, trojan, trojans, floppy
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING48 to get a discount on developer and team plans!


Newspaper

We sent a web developer to the store to get The Times newspaper. He came back with The Times New Roman.
<< < > >>
https://comic.browserling.com/extra/49
Cartoon tags:
font, type, times new roman, the times, newspaper, fonts, types, store, book store, typography, new roman
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING49 to get a discount on developer and team plans!


Java Cafe

The programmer forgot to update Java, so he went to the coffee shop to get a fresh one.
<< < > >>
https://comic.browserling.com/extra/50
Cartoon tags:
java, java programmer, jar, update, upgrade, coffee, caffeine, cafe, coffee shop, fresh coffee, out of date
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING50 to get a discount on developer and team plans!


Incognito

How do you know when you're really in incognito mode? ... Your browser turns into a Word document.
<< < > >>
https://comic.browserling.com/extra/51
Cartoon tags:
incognito, word, document, word document, chrome, google browser, firefox, mozilla, private browsing, google chrome, mozilla firefox, chrome browser, firefox browser, desk, mouse, computer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING51 to get a discount on developer and team plans!


Attack Vectors

Real hacker's attack vectors are normalized.
<< < > >>
https://comic.browserling.com/extra/52
Cartoon tags:
hacker, cracker, vector, attack vector, normalization, normalized vector, vectors, normalized, hackers, crackers, computers, it, security, network security, unit vector, mathematics, gram schmidt
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING52 to get a discount on developer and team plans!


F1

Why did the programmer drown?... Because he shouted "F1! F1!" and no one could understand him.
<< < > >>
https://comic.browserling.com/extra/53
Cartoon tags:
f1, help, swim, swimming, drown, water, programmer, keyboard
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING53 to get a discount on developer and team plans!


Llama

Winamp - it really whips the llama's ass!
<< < > >>
https://comic.browserling.com/extra/54
Cartoon tags:
llama, winamp, whip, mp3, music player, software
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING54 to get a discount on developer and team plans!


Minecraft

Minecraft - display block - CSS Pun
https://comic.browserling.com/extra/55
Cartoon tags:
minecraft, css, css pun, pig, creeper, game
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING55 to get a discount on developer and team plans!


Tetris

Boom! Tetris for Jonas!
<< < > >>
https://comic.browserling.com/extra/56
Cartoon tags:
tetris, boom, jonas, line piece, game
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING56 to get a discount on developer and team plans!