A weekly comic about programming, browsers and geek stuff.

Chrome

The hungriest browser.
https://comic.browserling.com/76
Cartoon tags:
chrome, browser, ram, memory, hungry, hunger, food, fat
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING76 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.