A weekly comic about programming, browsers and geek stuff.

Apple Pie

If you wish to make an apple pie from scratch, you must first invent the Universe.
https://comic.browserling.com/extra/29
Cartoon tags:
carl sagan, apple pie, universe, cosmos, food, science, galaxy, galaxies, milky way
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING29 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.