A weekly comic about programming, browsers and geek stuff.

Browsing History

An empty Internet browser is an automatic admission of guilt.
https://comic.browserling.com/extra/31
Cartoon tags:
browser, history, guilty, guilt, internet browser, internet history, browser history, incognito, police, police man, web browser, browsers, innocent, not guilty, private browsing
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING31 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.