A weekly comic about programming, browsers and geek stuff.

EA Games

EA Programming Team
https://comic.browserling.com/extra/11
Cartoon tags:
ea, ea games, electronic arts, dinosaurs, programming, team, mass effect
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING11 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.