A weekly comic about programming, browsers and geek stuff.

Grandpa

My grandpa never got to experience the Internet. Not because he was too old, but because he used Internet Explorer.
https://comic.browserling.com/extra/24
Cartoon tags:
grandpa, internet explorer, browser, ie, explorer, iexplore, iexplorer, grandpap, grandfather, computer, coffee, clock, grandpa joke
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING24 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.