A weekly comic about programming, browsers and geek stuff.

Peter Pan

Why is Peter Pan always flying? Because he Neverlands.
https://comic.browserling.com/extra/19
Cartoon tags:
peter pan, neverland, fly, flying, ship, island, tink, tinker bell
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING19 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.