A weekly comic about programming, browsers and geek stuff.

Grandma

My grandma never got to experience the Internet. Not because she was too old, but because she used Internet Explorer.
https://comic.browserling.com/3
Cartoon tags:
grandma, internet explorer, ie, internet, web, grand mom, grandmom, grand mother, grandmother, explorer, iexplorer, computer, iexplore.exe
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING3 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.