A weekly comic about programming, browsers and geek stuff.

Internet Exploder

Everyone's preferred browser.
https://comic.browserling.com/81
Cartoon tags:
ie, internet explorer, internet exploder, bomb, timer, explosion, iexplore, iexplorer, explorer, iexploder, exploder, iexplode, 1 second
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING81 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.