A weekly comic about programming, browsers and geek stuff.

Opera

Internet Explorer is one of the slowest tools for downloading Opera.
https://comic.browserling.com/55
Cartoon tags:
opera, ie, internet explorer, download, install, iexplore, explorer, browser, browsers, o, download and install opera, download opera, install opera, wdywtgt, where do you want to go today, microsoft
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING55 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.