A weekly comic about programming, browsers and geek stuff.

Shopping

Internet Explorer goes shopping. Employee asks, "Do you need help?" Internet Explorer responds, "No, just browsing."
https://comic.browserling.com/14
Cartoon tags:
internet explorer, ie, shopping, shop, employee, browse, browsing, iexplore, explorer, iexplorer, iexplorer.exe, store
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING14 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.