A weekly comic about programming, browsers and geek stuff.

Tux Party

Happy 25th Birthday, Linux!
https://comic.browserling.com/52
Cartoon tags:
tux, linux, party, birthday, 25, birthday party, 25th birthday, ghost, bitmask, dinosaurs, java, internet explorer, wine, dog, balloons, punch cards
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING52 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.