A weekly comic about programming, browsers and geek stuff.

Where do you want to go today?

Internet Explorer does a great job of downloading Chrome.
https://comic.browserling.com/6
Cartoon tags:
wdywtgt, ie, internet explorer, iexplore, explorer, iexplore.exe, chrome, google chrome, google, microsoft, where do you want to go today, download, install
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING6 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.