A weekly comic about programming, browsers and geek stuff.

Winamp

It really whips the llama's ass!
https://comic.browserling.com/13
Cartoon tags:
winamp, llama, whip, mp3, music player, software
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING13 to get a discount on developer and team plans!
(c) 2018 Browserling Inc. All rights reserved.